[백준, BOJ 6810] ISBN (python)
Problem Solving/BOJ

[백준, BOJ 6810] ISBN (python)

728x90

https://www.acmicpc.net/problem/6810

 

6810번: ISBN

The International Standard Book Number (ISBN) is a 13-digit code for identifying books. These numbers have a special property for detecting whether the number was written correctly. The 1-3-sum of a 13-digit number is calculated by multiplying the digits a

www.acmicpc.net


문제

The International Standard Book Number (ISBN) is a 13-digit code for identifying books. These numbers have a special property for detecting whether the number was written correctly.

The 1-3-sum of a 13-digit number is calculated by multiplying the digits alternately by 1’s and 3’s (see example) and then adding the results. For example, to compute the 1-3-sum of the number 9780921418948 we add

9 ∗ 1 + 7 ∗ 3 + 8 ∗ 1 + 0 ∗ 3 + 9 ∗ 1 + 2 ∗ 3 + 1 ∗ 1 + 4 ∗ 3 + 1 ∗ 1 + 8 ∗ 3 + 9 ∗ 1 + 4 ∗ 3 + 8 ∗ 1

to get 120.

The special property of an ISBN number is that its 1-3-sum is always a multiple of 10.

Write a program to compute the 1-3-sum of a 13-digit number. To reduce the amount of typing, you may assume that the first ten digits will always be 9780921418, like the example above. Your program should input the last three digits and then print its 1-3-sum. Use a format similar to the samples below.

728x90

예제 입력 1

9
4
8

예제 출력 1

The 1-3-sum is 120

# 13자리 수를 한 자리 씩 1과 3을 번갈아 곱하여 총 더하는 것이 1-3-sum이다.
# 앞의 10자리는 9780921418로 고정이고, 뒤의 3자리를 입력 받아 1-3-sum을 구하여 출력하라.
# 9780921418의 1-3-sum은 91이다.
# a, b, c를 입력 받으면, 91 + a*1 + b*3 + c*1 한 것이 답

a = int(input())
b = int(input())
c = int(input())

print('The 1-3-sum is', 91 + a + b * 3 + c)
728x90