[백준, BOJ 3733] Shares (python)
Problem Solving/BOJ

[백준, BOJ 3733] Shares (python)

728x90

https://www.acmicpc.net/problem/3733

 

3733번: Shares

A group of N persons and the ACM Chief Judge share equally a number of S shares (not necessary all of them). Let x be the number of shares aquired by each person (x must be an integer). The problem is to compute the maximum value of x. Write a program that

www.acmicpc.net


문제

A group of N persons and the ACM Chief Judge share equally a number of S shares (not necessary all of them). Let x be the number of shares aquired by each person (x must be an integer). The problem is to compute the maximum value of x.

Write a program that reads pairs of integer numbers from an input text file. Each pair contains the values of 1 ≤ N ≤ 10000 and 1 ≤ S ≤ 109 in that order. The input data are separated freely by white spaces, are correct, and terminate with an end of file. For each pair of numbers the program computes the maximum value of x and prints that value on the standard output from the beginning of a line, as shown in the example below.

728x90

 

예제 입력 1

1 100
2 7
10 9
10 10

예제 출력 1

50
2
0
0

arr = []

while(True):
    try:
        n, s = map(int, input().split())
        arr.append(s // (n + 1))
    except:
        for i in arr:
            print(i)
        break
728x90