728x90
https://www.acmicpc.net/problem/1753
문제
방향그래프가 주어지면 주어진 시작점에서 다른 모든 정점으로의 최단 경로를 구하는 프로그램을 작성하시오. 단, 모든 간선의 가중치는 10 이하의 자연수이다.
입력
첫째 줄에 정점의 개수 V와 간선의 개수 E가 주어진다. (1 ≤ V ≤ 20,000, 1 ≤ E ≤ 300,000) 모든 정점에는 1부터 V까지 번호가 매겨져 있다고 가정한다. 둘째 줄에는 시작 정점의 번호 K(1 ≤ K ≤ V)가 주어진다. 셋째 줄부터 E개의 줄에 걸쳐 각 간선을 나타내는 세 개의 정수 (u, v, w)가 순서대로 주어진다. 이는 u에서 v로 가는 가중치 w인 간선이 존재한다는 뜻이다. u와 v는 서로 다르며 w는 10 이하의 자연수이다. 서로 다른 두 정점 사이에 여러 개의 간선이 존재할 수도 있음에 유의한다.
출력
첫째 줄부터 V개의 줄에 걸쳐, i번째 줄에 i번 정점으로의 최단 경로의 경로값을 출력한다. 시작점 자신은 0으로 출력하고, 경로가 존재하지 않는 경우에는 INF를 출력하면 된다.
728x90
예제 입력 1
5 6
1
5 1 1
1 2 2
1 3 3
2 3 4
2 4 5
3 4 6
예제 출력 1
0
2
3
7
INF
import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.util.ArrayList;
import java.util.PriorityQueue;
import java.util.StringTokenizer;
class Node implements Comparable<Node> {
private int index;
private int distance;
public Node(int index, int distance) {
this.index = index;
this.distance = distance;
}
public int getIndex() {
return this.index;
}
public int getDistance() {
return this.distance;
}
// 거리가 짧은 것이 높은 우선순위를 가지도록 설정
@Override
public int compareTo(Node other) {
return this.distance - other.getDistance();
}
}
public class Main {
static ArrayList<ArrayList<int []>> list;
static int[] distance;
private static void dijk(int start) {
PriorityQueue<Node> pq = new PriorityQueue<>();
pq.add(new Node(start, 0)); // 시작 정점 큐에 삽입
distance[start] = 0; // 시작 정점의 거리는 0
while(!pq.isEmpty()) { // 큐가 빌 때까지
Node tmp = pq.poll(); // 가장 거리가 짧은 정점의 정보 꺼내기
int now = tmp.getIndex(); // 현재 정점
int dis = tmp.getDistance(); // 현재 정점의 최단 거리
if(distance[now] < dis) continue; // 현재 정점이 이미 처리된 적 있는 정점이면 무시
ArrayList<int []> nowList = list.get(now); // 현재 정점에 연결되어 있는 간선 정보 가져오기
for (int i = 0; i < nowList.size(); i++) {
int cost = dis + nowList.get(i)[1];
// 현재 정점을 거쳐서 다음 정점으로 가는 길이가 더 짧다면
if(cost < distance[nowList.get(i)[0]]) {
distance[nowList.get(i)[0]] = cost; // 현재 정점을 거쳐서 가게 해주고
pq.add(new Node(nowList.get(i)[0], cost)); // 큐에 넣어줌
}
}
}
}
public static void main(String[] args) throws Exception{
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
StringTokenizer st;
StringBuilder sb = new StringBuilder();
// 정점의 개수 V, 간선의 개수 E 입력
st = new StringTokenizer(br.readLine());
int V = Integer.parseInt(st.nextToken());
int E = Integer.parseInt(st.nextToken());
// 시작 정점의 번호 K
int K = Integer.parseInt(br.readLine());
// E개의 간선 정보 입력
// 가장 가까운 경로 저장할 배열 최대값으로 초기화
list = new ArrayList<>();
distance = new int[V + 1];
for (int i = 0; i <= V; i++) {
list.add(new ArrayList<>());
distance[i] = Integer.MAX_VALUE;
}
for (int i = 0; i < E; i++) {
st = new StringTokenizer(br.readLine());
int u = Integer.parseInt(st.nextToken());
int v = Integer.parseInt(st.nextToken());
int w = Integer.parseInt(st.nextToken());
list.get(u).add(new int[] {v, w});
}
// 정점 거리 구해주기
dijk(K);
// 출력
for (int i = 1; i <= V; i++) {
if(distance[i] == Integer.MAX_VALUE) sb.append("INF\n");
else sb.append(distance[i] + "\n");
}
System.out.println(sb);
}
}
728x90
'Problem Solving > BOJ' 카테고리의 다른 글
[백준, BOJ 1058] 친구 (java) (0) | 2023.02.19 |
---|---|
[백준, BOJ 11404] 플로이드 (java) (0) | 2023.02.18 |
[백준, BOJ 10971] 외판원 순회 2 (java) (0) | 2023.02.18 |
[백준, BOJ 18352] 특정 거리의 도시 찾기 (java) (0) | 2023.02.18 |
[백준, BOJ 3040] 백설 공주와 일곱 난쟁이 (java) (0) | 2023.02.18 |