[백준, BOJ 2744] 대소문자 바꾸기 (python)
Problem Solving/BOJ

[백준, BOJ 2744] 대소문자 바꾸기 (python)

728x90

https://www.acmicpc.net/problem/2744

 

2744번: 대소문자 바꾸기

영어 소문자와 대문자로 이루어진 단어를 입력받은 뒤, 대문자는 소문자로, 소문자는 대문자로 바꾸어 출력하는 프로그램을 작성하시오.

www.acmicpc.net


문제

영어 소문자와 대문자로 이루어진 단어를 입력받은 뒤, 대문자는 소문자로, 소문자는 대문자로 바꾸어 출력하는 프로그램을 작성하시오.

입력

첫째 줄에 영어 소문자와 대문자로만 이루어진 단어가 주어진다. 단어의 길이는 최대 100이다.

출력

첫째 줄에 입력으로 주어진 단어에서 대문자는 소문자로, 소문자는 대문자로 바꾼 단어를 출력한다.

728x90

예제 입력 1

WrongAnswer

예제 출력 1

wRONGaNSWER

ord, chr 함수 사용

string = input()
result = ""

for s in string:
    #대문자라면
    if ord(s) >= ord('A') and ord(s) <= ord('Z'):
        result += chr(ord(s) - ord('A') + ord('a'))
    #소문자라면
    else:
        result += chr(ord(s) - ord('a') + ord('A'))

print(result)

swapcase 함수 사용

string = input()

print(string.swapcase())

isupper, upper, lower 함수 사용

string = input()
result = []

for s in string:
    if s.isupper():
        result.append(s.lower())
    else:
        result.append(s.upper())

print(''.join(result))
728x90